Error restoring bizagi database

I have an issue regarding the restore of a bizagi project. More specifically, I have a SQL server backup file of the project which I successfully restored (following exactly this guide Then I create a new bizagi project and I select as the database the one that I restored. When I try to open the project the following error appears: Error Object reference not set to an instance of an object

Thus the project will not open. Please note that:

  • -This problem only happens in my computer. I have tested the same backup file in

    another computer with exactly the same bizagi & sql server version

    using the same procedure and it works perfectly. Thus there is not a problem in the backup file.

  • -I have successfully restored many other bizagi projects using the same method. The only project that gives me an error is this one.
  • I run Microsoft SQL server 2014 locally in my Windows 10 dell laptop. Bizagi Studio version

I unsuccessfully have tried to:

1) Reboot PC/Internet

2) Shut down firewall

3) Re-install bizagi studio

4) Install SQL server 2008 R3 and try on that server.

5) Restored the project in another pc (which, as mentioned before, worked correctly). Then create a new backup of the SQL database from that pc. This backup also did not work in my computer.

6) Update BIOS, CPU/GPU drivers and etc updates

7) Installing the latest version of Bizagi Studio (

I still have the same problem. I have already made a ticket to bizagi but since I have not got an answer yet, I am posting it here. Perhaps someone else has the same problem?

Comments (2)


Dear Andreas

Once you create a project, are you doing the "Change Database" to point it to the one you restored previously?

The other alternative is to first create a Project, and then overlay the project database with your back up file.

Please follow these steps to restore the backup file and let us know :

We look forward to hearing from you.

Best Regards


Yes I doing a "Change Database". I am familiar with that procedure since I have successfully recovered many other projects.

I have done a research on the topic and I found out that the problem is caused by a specific server collation. However i cannot find a solution for this. I have created a new topic in which I specify my problem:

Thus this topic should be closed.

Thank you!