This object is in archive! 
Solved

Erro: My form did not open..What can Ido to fix this problem?

Dr Sr,

I was elaborating my form with inserting tables and relating with the dats from my Data model. When I tried to open this form the bug "Guid = 2ff6e1fd-fcb5-4d52-a464-a47c5e921704 not exist on valid tables (ATTIB, FACT, BASCOPEITEMDEF, ENTITY) for XPath elem" appeared.

The Details of error:

"System.Exception: Guid = 2ff6e1fd-fcb5-4d52-a464-a47c5e921704 not exist on valid tables (ATTIB, FACT, BASCOPEITEMDEF, ENTITY) for XPath elements

at Bizagi.Catalog.XPath.GlobalXPathParser.GetName(Guid guid)

at Bizagi.Catalog.XPath.GlobalXPathParser.Deserialize(String xpathPointerFormat, List`1 references)

at Bizagi.MD.PersistenceServices.Catalog.Serialization.Json.XPathResolver.Deserialize(CatalogObject obj, JToken json)

at Bizagi.MD.PersistenceServices.Catalog.Serialization.Json.ReferenceParser.DeserializeJson(CatalogObject obj, JToken token)

at Bizagi.MD.PersistenceServices.Catalog.Serialization.Json.ReferenceParser.Deserialize(CatalogObject obj, OutputValue& content)

at Bizagi.MD.PersistenceServices.Catalog.Serialization.Json.JsonStringContentSerializer.Deserialize[T](CatalogObject obj)

at Bizagi.MD.PersistenceServices.Catalog.CatalogDataStore.Load[T](Guid guid, EMetadataItem catalogItem)

at Bizagi.MD.CatalogServices.CatalogServicesManager.Load[T](Guid guid, EMetadataItem catalogItem)

at Bizagi.MD.Services.ServiceBase`1.GetById(Guid id)

at Bizagi.MD.Services.Forms.FormServices.GetById(Guid id)

at Bizagi.MD.Services.Forms.FormFacade.GetFormById(Guid idForm)

at BizAgiStudio.Forms.Modeler.Web.Loader.DataAccessManager.GetForm(Guid idForm)

at BizAgiStudio.Forms.Modeler.Web.Editor.Presenter.ModelerWebPresenter.LoadForm(Guid idForm)

at BizAgiStudio.Forms.Modeler.Web.Editor.View.FrmModelerWeb.OpenForm(Guid idForm)

at BizAgiStudio.Forms.Modeler.Web.FormsModelerProcessArchitectureFacadex86.OpenForm(Guid idForm, Action`1 formClosed, Boolean isShowDialog)

at BizAgiStudio.Forms.Modeler.Web.WebFormsModelerFacade.OpenForm(Guid idForm, Action`1 formClosed)

at BizAgiStudio.Forms.Modeler.Web.WebFormsModelerFacade.OpenForm(Guid idForm)

at Castle.Proxies.Invocations.IWebFormsModelerFacade_OpenForm.InvokeMethodOnTarget()

at Castle.DynamicProxy.AbstractInvocation.Proceed()

at Castle.DynamicProxy.AbstractInvocation.Proceed()

at BizAgiStudio.EntityManagerPlugin.Logic.FormsPlugInLogic.EditForm(Guid formId, Int32 formsVersion)

at BizAgiStudio.EntityManagerPlugin.Logic.FormsPlugInLogic.OpenForm(FormsLogicParam p)

at BizAgiStudio.Carrousel.Controls.CarrouselContainer.HandleShapeClickForDefineForms(ModelerProcessControl processControl, BaseShape shape)

at BizAgiStudio.Carrousel.Controls.CarrouselContainer.OnModelerProcessControlShapeClick(Object sender, CrainiateElementEventArgs`1 e)

at BizAgi.PM.UI.Controls.DiagramFlowChart.OnElementClick(Element element)

at Crainiate.ERM4.Diagram.OnClick(EventArgs e)

at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)

at System.Windows.Forms.Control.WndProc(Message& m)

at Crainiate.ERM4.Diagram.WndProc(Message& m)

at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)"

How can I solve this?

I want to fix what is wrong and keep doing my process.

Thanks

Comments (3)

photo
1

Only to add my bizagi version is 10.7..

Thanks

photo
1

Dear Flávia,

To solve this issue, please upgrade your current version. Click here to download: https://bizagi.sharefile.com/d-sf9977e81ec24d019

We look forward to hearing from you

Regards

photo
1

Dear Juan,

I did the upgrade of my version and the problem has continued.. So I decided to erase that form(activity) and create a new form (activity) with the same requisits.

Regards. .