CHelper.trace does not perform in filter expression?


I followed the documentation below:

I have created filter expressions that work fine. In it, I included CHelper.trace as I wanted to display some info, for the test I have set it to some random pure-string expression just to make sure it works.

For some reason, while the filter still performing the file, the tracer does not write in the specified file, located in


Is tracing disabled in filter expressions?

Bizagi Studio version:

Kind regards,

Dejan Penko

Comments (4)


Good afternoon Dejan,

I recommend that you put the trace in an action when entering, saving or exiting, in this way you make sure that it is executed in any of the moments.

Andres Montoya


Hi, thank you for a fast reply.

I've just tried it. I've set an expression using the trace method to save the Activity action (on save) and still no effect, there is no trace/log file created.

The expression does run, as I've added in the same expression ThrowValidationAlert and it works fine.

Please see the attachment for more info.

Am I missing something?

Kind regards,



I've found out what was the issue, possibly also in the first case...

I was running ThrowValidationAlert before tracing (was testing which method would be the best to display the value of the variable).

And when ThrowValidationAlert is thrown the rest of the expression does not execute...


I confirm. CHelper.trace works in filter expression (when executed!).