En progreso

Lentitud para modelar diagramas

Buen día, por favor quisiera que me ayudaran. Desde hace ya bastante tiempo tengo problemas para modelar con Bizagi.

Cuando un diagrama de flujo es pequeño o sencillo, todo funciona normal. Pero, en la medida que este va creciendo, el software se va ralentizado al punto que, para hacer alguna acción (como agregar una actividad, o mover cualquier objeto) puede tardar hasta 5 segundos. Tengo que estar cerrando y abriendo el diagrama de manera constante. Se recupera por un breve lapso de tiempo y luego vuelve a presentar el mismo patrón de problema. Esto hace que se vuelva insostenible modelar.

En la medida que iban actualizando de versión, creía que se solucionaría ese problema, pero veo que hasta ahora persiste. Ello no me pasaba con las versiones 2.x

Teniendo en cuenta que una buena práctica de la gestión por procesos es el enfoque end to end (punta a punta), naturalmente los diagramas de flujos van a tener una complejidad razonable. Sin embargo, en mi experiencia, los modelos que actualmente desarrollo no los considero extremadamente complejos. Por lo que me extraña que el software se comporte de esa manera.

Cuento con una notebook potente. Por lo que no es un problema de capacidad de hardware.

Les comparto dos ejemplos de modelos. El Ejemplo 1 es un diagrama donde puedo continuar trabajando sin poblema (no se pone lento). El Ejemplo 2 es un diagrama donde el software se pone muy lento para hacer cada cambio (de hecho sufrí mucho para llegar a terminarlo). Considero que este último ejemplo no representa un proceso que sea muy complejo. He visto modelos mucho más complejos que este modelados en otros softwares.

Agradecería que se tomen un tiempo para revisar este caso. Aprecio mucho Bizagi y no quiero cambiar de modelador. Pero, si el problema persiste, me veré obligado a hacerlo ya que mis procesos suelen ser de End to End.

Gracias,

Comentarios (2)

photo
1

Estimado Henry,

Muchas gracias por tomarte el tiempo para escribir esta experiencia tuya utilizando Bizagi Modeler y posteriormente haberla compartido con nosotros. Esta información será compartida con las personas del equipo de Modeler y será una referencia respecto a todo el tema de mejoras en cuestión de performance. De ser necesario, te contactaremos vía correo electrónico para profundizar en el tema.

Saludos cordiales.

photo
1

Nosotros hemos notado que, sin importar el tamaño, pongo una línea de flujo para luego conectar 2 procesos, al momento que intentamos mover cada extremo de la línea, se tarda mucho tiempo en reaccionar bizagi. Me da la impresión como si quisiera recorrer el token y al llegar a la línea o flecha que no está conectada no sabe que hacer el engine.