In Progress

Not supported event definition for an intermediate throw event error. Can't save the model

I can't save the model! When I try to do it, it says 'Not supported event definition for an intermediate throw event'. The validation button is not working so nothing happens when I press it. I have even deleted all the intermediate events. Please help me to finally close the app and get my model out of it.

P.S. scrn_17.png is how the model looks now (the same but with no intermediate events)

Comments (2)

photo
2

Dear Игорь,

Thank you for letting us know about this issue. Since you were kind enough to also comment on a previous solved post, we will take that into account and answer to both this topic and the comment here:

Regarding this original topic: The error you mention happens when an intermediate throw event is not correctly defined or used within a diagram. Therefore, we suggest going through each event and make sure the parameters are defined according to the event type you chose (we would even suggest moving around the elements to see if there's an intermediate event hidden somewhere, but you mentioned that the error is thrown even with all elements deleted). Also, please take into account the recommendations for intermediate events explained in these articles: https://help.bizagi.com/process-modeler/en/index.html?events.htm and https://help.bizagi.com/process-modeler/en/index.html?best_practices_in_modeling.htm

Now, regarding the comment, the reason why we cannot look deeper into the causes of the errors ourselves is because these errors are too specific to find them without the original model that is causing them (your model, in this case), and since according to your report you cannot save the model as it is, it makes no sense asking you to send it to us. However, since you already tried deleting all the elements to see the same error thrown at you, we would suggest that it's an issue with the metadata of the model (some event "stuck" in the model but invisible to correct it directly); so, our suggestion would be to move your elements to a new model file and save that new file, and then force-exit the program in case it won't close normally due to the error in the previous file.

We are sorry that you are experiencing some issues and hope they will be solved promptly.

Best regards,

Laura G

photo
1

Thank you for your detailed reply! I tried to copy-paste the elements from one model to another but to no avail, they wouldn't paste. Were there any other means of moving the elements? Sadly, I've already closed the model so I can't try any further. Happily, I didn't experience the issue with the new model.