In Progress

Error message when saving with formatted text


Whenever I use a formatted text I get an error message, when I try to save. The message reads as following:

Error saving Model:

Illegal character in path.

This happens as soon as I enter any text in the field. When I delete the text (the field is now empty) I can save without a problem.

I save locally on the harddisk, the actual path does not make a difference, I tried different paths.

Happens with Modeler Version

Am I missing something here?

Comments (3)


Dear Sascha,

Thank you for letting us know. This usually happens when there is a hidden character somewhere in the metadata of the model. Our recommendation then would be to try and open the file using some editor such as Sublime Text or Visual Studio, so that the model opens as an xml file, then you will be able to find the hidden character that is causing issues with your model.

Let us know if it helps or if you require further assistance.

Kind regards,

Laura G


Thank you for the reply.

Unfortunately, I was not able to open the model as an XML file in any editor (I even downloaded Sublime Text), but that’s on me, as I’m not that experienced in that kind of things. I am just wondering, if it is a problem in the model, why does this happen with every model, even new ones (create a new blank model, insert Formatted text and only type in an “a”)? And only when I am using Formatted text, and even then, only when the field is not empty?

Anyway, I found a workaround: If I save the model as a new model, the same error appears, but it saves the Formatted text in the new model. Not the most convenient solution, but at least it works. Since I am making only pretty simple models, this is ok for me and I can live with that.


I have the same problem, you just explained what is happenig to me too. It's for all the new ones I create.