Cannot Uninstall Old Version

Unable to update to latest version of BizAgi process modeler because of an old version.

Whenever BizAgi launches, the user is prompted to upgrade to the newest version. After downloading and attempting to install the new version, the installer throws an error stating that the old version of BizAgi could not be uninstalled, and to use Control Panel to perform the uninstall. When attempting to uninstall via programs and features, the uninstaller agent instantly crashes. There are two versions of BizAgi listed in the programs and features section, the new version will uninstall, the old will not.

Tried restarting computer multiple times, deleting folders/editing registry, nothing has been successful so far.

I do have admin rights on the computer, the end-user does not. Windows 7 x64. Old version that will not uninstall was either 2.6.04 or 2.6.14.

Comments (6)


Dear Joseph,

In order to solve this problem, please download and execute a program called CCleaner - trial version - ( in order to clean the register. After that, try again to install the new version.

ccleaner3We look forward for your procedure,Regards


I did a complete clean of the registry with ccleaner and wise registry analyzer. Deleted folders left by uninstall process. still locked when trying to re-install..


Dear Paolo,

Please check the following key in the regedit windows:


Then, delete it and try again.



solved! I did a complete scan with auslogics registry cleaner, then searched for "bizagi" and deleted everything.

Reinstall ok.

btw, that cleaner is the only one that works among a dozen i tried out (the most famous).

also, deleted bizagi folder in program files with file assassin (a few jre font files were locked).

thanks for the assistance




I did all the procedures above and the resul is the same. It informs tha and older version must be removed using control panel.

I scanned registy with ccleaner and Auslogics. I searched for that key in Hkey_Local_Machine and itsn't there, so I don't know what else I can do.

It would be nice if I knew where the installer checks for installed version.


Dear Leandro,

It does. The installer checks if there is a previous version and proceed to un-install before to install the new version. To help you to solve this issue, please send us screenshots of the problem.

In addition, try to install x32Bits instead of x64Bits using administrator rights. You can download it from:

We look forward to hearing from you