This object is in archive! 
Nuevo

Problemas de configuración con JBOSS y Bizagi Console

Hola

Tengo instalado: LimuxAMI(Oracle 11g, JBOSS 6.2) y Windows7(Bizagi Studio 10.7)

Al intentar generar un nuevo proyecto desde BizAgi Studio, recibo el siguiente error en pantalla.

849a28c4687f72c83d7a9a37d24ebf03

He suuesto que el problema puede darse por que no esta instalado el plug in de JBOSS de Bizagi por lo que he intentado configurarlo sin éxito. Puedo iniciar el JBOSS y entrar así a la pantalla de bienvenida y la consola mas al hacer el deploy del BizAgi-ear-JBoss.ear que he puesto directamente del zip al directorio de deploy. JBOSS marca el siguiente error en consola.

  1. 00:24:45,367 WARN

    [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class

    Path entry batik-ext-1.6-1.jar in

    /content/BizAgi-ear-JBoss.ear/BizAgi-war.war

    does not point to a valid jar for a Class-Path reference.

  2. 00:24:45,367 WARN

    [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960:

    Class Path entry itext-1.4.8.jar in

    /content/BizAgi-ear-JBoss.ear/BizAgi-war.war

    does not point to a valid jar for a Class-Path reference.

  3. 00:24:45,612 ERROR [org.jboss.msc.service.fail] (MSC

    service thread 1-1) MSC000001: Failed to start service

    jboss.deployment.subunit."BizAgi-ear-JBoss.ear"."BizAgi-ejb.jar".PARSE:

    org.jboss.msc.service.StartException in service

    jboss.deployment.subunit."BizAgi-ear-JBoss.ear"."BizAgi-ejb.jar".PARSE:

    JBAS018733: Failed to process phase PARSE of subdeployment "BizAgi-ejb.jar"

    of deployment "BizAgi-ear-JBoss.ear"

  4. at

    org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:127)

    [jboss-as-server-7.3.0.Final-redhat-14.jar:7.3.0.Final-redhat-14]

  5. at

    org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811)

    [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]

  6. at

    org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746)

    [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]

  7. at

    java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)

    [rt.jar:1.7.0_111]

  8. at

    java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)

    [rt.jar:1.7.0_111]

  9. at

    java.lang.Thread.run(Thread.java:745) [rt.jar:1.7.0_111]

  10. Caused by:

    org.jboss.msc.service.ServiceNotFoundException: Service service

    jboss.ejb.default-resource-adapter-name-service not found

  11. at

    org.jboss.msc.service.ServiceContainerImpl.getRequiredService(ServiceContainerImpl.java:448)

    [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]

  12. at

    org.jboss.as.ejb3.deployment.processors.MessageDrivenComponentDescriptionFactory.getDefaultResourceAdapterName(MessageDrivenComponentDescriptionFactory.java:270)

  13. at

    org.jboss.as.ejb3.deployment.processors.MessageDrivenComponentDescriptionFactory.processMessageBeans(MessageDrivenComponentDescriptionFactory.java:152)

  14. at

    org.jboss.as.ejb3.deployment.processors.MessageDrivenComponentDescriptionFactory.processAnnotations(MessageDrivenComponentDescriptionFactory.java:80)

  15. at

    org.jboss.as.ejb3.deployment.processors.AnnotatedEJBComponentDescriptionDeploymentUnitProcessor.processAnnotations(AnnotatedEJBComponentDescriptionDeploymentUnitProcessor.java:58)

  16. at org.jboss.as.ejb3.deployment.processors.AbstractDeploymentUnitProcessor.deploy(AbstractDeploymentUnitProcessor.java:81)
  17. at

    org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:120)

    [jboss-as-server-7.3.0.Final-redhat-14.jar:7.3.0.Final-redhat-14]

  18. ... 5 more

Supuse que el problema que tenga este error es por que no está instalada la consola de Bizagi; sin embargo, en el paso de predeply surge el siguiente error en la consola:

  1. [BizagiJEEConsole:PREDEPLOY] ERROR: Bizagi version could not be generated.
  2. Error detail: Error generating entities: Exception [EclipseLink-4002] (Eclipse Persistence Services - 2.5.0.v20130507-3faac2b): org.eclipse.persistence.exceptions.DatabaseException
  3. Internal Exception: java.sql.SQLSyntaxErrorException: ORA-00942: table or view does not exist
  4. Error Code: 942
  5. Call: SELECT idEnt, dplyEnt, entContentType, entDescription, entDisplayAttrib, entDisplayName, entExtSrc, entLogged, entName, entReplicated, entSrc, entSrcCacheTimeOut, entSrcGlobalTimeOut, entSrcSystem, entSrcType, entSurrogateKey, entType, guidEnt, idSrcProvider, idParentEnt FROM ENTITY
  6. Query: ReadAllQuery(referenceClass=Entity sql="SELECT idEnt, dplyEnt, entContentType, entDescription, entDisplayAttrib, entDisplayName, entExtSrc, entLogged, entName, entReplicated, entSrc, entSrcCacheTimeOut, entSrcGlobalTimeOut, entSrcSystem, entSrcType, entSurrogateKey, entType, guidEnt, idSrcProvider, idParentEnt FROM ENTITY")

Solicito su ayuda para destrabar algún componente de mi instalación. supongo que algo le debo prestar mas atención pero no logro encontrar que paso de la documentación es el que he omitido.

¡Gracias!.