No es un problema

Error al invocar metodo createCases de la capa SOA

Buenos días,

estoy probando la creación de casos a través de la capa SOA de Bizagi Xpress.

Tengo un proceso con una entidad principal básica con un solo atributo. El xml que utilizo contiene lo siguiente:

<BizagiWSParam>

<domain>admon</domain>

<userName>domain</userName>

<Cases>

<Case>

<Process>Prueba</Process>

<Entities>

<App>

<Prueba>

<Nombre>test</Nombre>

</Prueba>

</App>

</Entities>

</Case>

</Cases>

</BizagiWSParam>

Al invocar el servicio createCases, siempre me devuelve:

<createCasesResponse xmlns="http://tempuri.org/">;

<createCasesResult>

<processes xmlns="">

<process>

<processId>0</processId>

<processRadNumber>0</processRadNumber>

<processError>

<errorCode>1</errorCode>

<errorMessage>Object reference not set to an instance of an object.</errorMessage>

</processError>

</process>

</processes>

</createCasesResult>

</createCasesResponse>

(Object reference not set to an instance of an object).

Evidentemente me está faltando algun dato que impide la creacion del Case, pero no sé que puede ser.

Les agradeceria mucho vuestra ayuda!

Mejor respuesta
photo

Estimado Roqueland,

Por favor revisar y tener en cuenta que los elementos XML de los métodos web de Bizagi son "case-senstive" (sensibles a mayúsculas).

Ante el detalle enviado, recuerde que se debe usar: "BizAgiWSParam" (con la A mayúscula).

Cordialmente,

photo
0

Estimado Roqueland,

Por favor revisar y tener en cuenta que los elementos XML de los métodos web de Bizagi son "case-senstive" (sensibles a mayúsculas).

Ante el detalle enviado, recuerde que se debe usar: "BizAgiWSParam" (con la A mayúscula).

Cordialmente,