Resuelto

Error al crear expresión con web service

Buenas,

Estoy tratando de crear una expresión con un servicio web pero al darle propiedades para iniciar el proceso de invocación al servicio web me sale el siguiente error:

System.IO.FileNotFoundException: No se puede cargar el archivo o ensamblado 'Infragistics2.Win.v7.3, Version=7.3.20073.1053, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb' ni una de sus dependencias. El sistema no puede encontrar el archivo especificado.

Nombre de archivo: 'Infragistics2.Win.v7.3, Version=7.3.20073.1053, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb'

en System.RuntimeTypeHandle.GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMarkHandle stackMark, IntPtr pPrivHostBinder, Boolean loadTypeFromPartialName, ObjectHandleOnStack type)

en System.RuntimeTypeHandle.GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean loadTypeFromPartialName)

en System.RuntimeType.GetType(String typeName, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark)

en System.Type.GetType(String typeName, Boolean throwOnError)

en System.Resources.ResourceReader.FindType(Int32 typeIndex)

en System.Resources.ResourceReader.DeserializeObject(Int32 typeIndex)

en System.Resources.ResourceReader.LoadObjectV2(Int32 pos, ResourceTypeCode& typeCode)

en System.Resources.ResourceReader.LoadObject(Int32 pos)

en System.Resources.ResourceReader.ResourceEnumerator.get_Entry()

en System.Resources.ResourceReader.ResourceEnumerator.get_Current()

en System.ComponentModel.ComponentResourceManager.FillResources(CultureInfo culture, ResourceSet& resourceSet)

en System.ComponentModel.ComponentResourceManager.FillResources(CultureInfo culture, ResourceSet& resourceSet)

en System.ComponentModel.ComponentResourceManager.FillResources(CultureInfo culture, ResourceSet& resourceSet)

en System.ComponentModel.ComponentResourceManager.ApplyResources(Object value, String objectName, CultureInfo culture)

en BizAgiStudio.BusinessRulesPlugIn.UserControls.WebServiceLocation.InitializeComponent()

en BizAgiStudio.BusinessRulesPlugIn.Forms.FrmWizardWebService.InitializeComponent()

en BizAgiStudio.BusinessRulesPlugIn.Forms.FrmWizardWebService..ctor(Int32 idContextEnt)

en BizAgiStudio.BusinessRulesPlugIn.Forms.FrmWizardWebServiceRuleModel..ctor(CCodeSnippet m_CodeSnippet, Int32 idContextEnt, DataTable dtDeclaredVariables)

en BizAgiStudio.BusinessRulesPlugIn.Rules.RuleView.RuleShapes.WebServiceShape.Edit()

en BizAgi.Admin.Forms.PopupMenuManager.OnPopupToolClick(Object sender, ToolClickEventArgs e)

en Infragistics.Win.UltraWinToolbars.UltraToolbarsManager.OnToolClick(ToolClickEventArgs e)

en Infragistics.Win.UltraWinToolbars.UltraToolbarsManager.FireEvent(ToolbarEventIds id, EventArgs e)

en Infragistics.Win.UltraWinToolbars.PopupMenuItemUIElement.DoClickProcessing(MouseEventArgs e)

en Infragistics.Win.UltraWinToolbars.PopupMenuItemUIElement.OnMouseUp(MouseEventArgs e)

en Infragistics.Win.TextUIElementBase.OnMouseUp(MouseEventArgs e)

en Infragistics.Win.ControlUIElementBase.ProcessMouseUpHelper(Object sender, MouseEventArgs e)

en Infragistics.Win.ControlUIElementBase.ProcessMouseUp(Object sender, MouseEventArgs e)

en Infragistics.Win.Utilities.ProcessEvent(Control control, ProcessEvent eventToProcess, EventArgs e)

en Infragistics.Win.UltraWinToolbars.PopupControlBase.OnMouseUp(MouseEventArgs e)

en System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)

en System.Windows.Forms.Control.WndProc(Message& m)

en System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Gracias de antemano por la ayuda.

Saludos cordiales,

Carlos Gutierrez

Comentarios (5)

photo
1

La versión de Bizagi es 11.0.0.2465.

photo
1

Estimado Carlos,

Queremos saber si puede invocar el web service a través de una tarea automática o si el problema solo se presenta desde una regla. Así mismo, queremos saber un mensaje diferente que nos ayuden a determinar el error. Para ello, por favor habilite los traces para evaluar la invocación de servicios web: http://help.bizagi.com/bpmsuite/es/index.html?studio_wstracing.htm

Quedamos atentos

photo
1

Estimado Juan,

A través de una tarea automática SI se puede invocar el servicio web. El problema solo se presenta cuando se quiere crear la regla. Adjunto imagen que muestra el momento cuando se presenta el error. Entiendo que el trace me serviría si pudiera crear la regla para poder invocar el servicio web, pero si ni siquiera puedo crear la regla como podría activar el trace?

Saludos cordiales,

Carlos Gutierrez

photo
1

Estimado Carlos,

Gracias por la información. Vamos entonces a replicar el error y le informaremos tan pronto como sea posible.

Saludos

photo
1

Estimado Carlos,

Por favor descargue la última versión de Bizagi 11 de nuestro sitio de descargas(http://www.bizagi.com/en/products/bpm-suite/studio#downloadstudio).

Esta semana fue actualizada la versión, en la cual, no se presenta el error que menciona.

Quedamos atentos