Solved

While starting Bizagi Studio getting Error message: Root element is missing

System.ApplicationException: Error in loading preferences file. ---> System.Xml.XmlException: Root element is missing.

at System.Xml.XmlTextReaderImpl.Throw(Exception e)

at System.Xml.XmlTextReaderImpl.ParseDocumentContent()

at System.Xml.XmlReader.MoveToContent()

at System.Data.DataSet.ReadXml(XmlReader reader, Boolean denyResolving)

at System.Data.DataSet.ReadXml(XmlReader reader, XmlReadMode mode, Boolean denyResolving)

at System.Data.DataSet.ReadXml(String fileName, XmlReadMode mode)

at BizAgiStudio.Plugin.CPreferences.LoadPreferencesDataSet()

--- End of inner exception stack trace ---

at BizAgiStudio.Plugin.CPreferences.LoadPreferencesDataSet()

at BizAgiStudio.Plugin.CPreferences.LoadPreferences()

at BizAgiStudio.Plugin.CBizAgiStudioAmbient..ctor(Form mainForm, RibbonControl ribbonControl, RibbonBar ribbonBarContext, StyleManager styleManager, UltraStatusBar statusBar)

at BizAgiStudio.FrmMain..ctor()

at BizAgiStudio.Program.Main(String[] Args)

Comments (2)

photo
2

Dear Rajat,

This issue happens because one of XML files is broken.

Check appsettings.xml file from C:\ProgramData\Bizagi\Enterprise\BizagiStudio and verify it. If it is broken, reemplace it the file with the attached file.

Check BizAgiProjects.xml file from C:\ProgramData\Bizagi and verify it. If it is broken, reemplace it the file with the attached file.

Note: Modify their values according your environment.

Regards

photo
1

Thanks a lot, Juan. It's working now.

Kind Regards