In Progress

Referenced assembly cannot be found. Custom .DLL

I am trying to use a custom .DLL. I have written it in C#, have added it to the component library under namespace testdll. The namespace in the class is also testdll and the class is called testdll. When I try and use it in an expression, I keep getting the error referenced assembly testdll.dll cannot be found.

When I manually add the .dll into the Bin folder of the project (WebApplication\bin) I still get the error, but the .dll is called properly and returns the proper results.

Why is this happening? Any help is much appreciated!

Comments (10)

photo
1

Dear Sam,

Regarding your question, you need to follow an example and some considerations to solve it:

Regards

photo
1

Hi Juan,

I have followed those tutorials to the T and am still having the issues. I'm compiling the .DLL in x64 for .NET 4 framework and it is still giving me the error that it can't find my referenced assembly. I also tried a .DLL that I've successfully used in the past and am getting the same error.

Do you have any other suggestions?

Thanks,

Sam

photo
1

Dear Sam,

Please bear in mind the following note:

When referencing libraries or APIs from third-party products, make sure you have evaluated if you can build the final component according to the expected system architecture of your production environment (i.e 64-bit vs 32-bit).

Consider further configuration possibilities in case that your component cannot be produced to comply with your system's architecture (i.e, such as producing the functions as Web services instead, separate from Bizagi).

When evaluating such libraries, you need to ensure that any third-party library is supported by the vendor, in order for your project to be able to handle and escalate issues to that vendor (i.e, any bug or performance issue produced by those third-party libraries).

In addition, I am attaching an example of a component library for MySQL to do a custom replication

Best Regards

photo
1

Hi, I am facing the same error. I tried also to compile the provided code and follow the corresponding article on Bizagi 10.7 (Data virtualisation) with no success. Getting the following error when I try to "Test Provider"

Could not load class BizagiMySQL.CMySQLProvider in assembly BizagiMySQL. - Exception has been thrown by the target of an invocation.


Please advise.

photo
1

Dear Lacovos,

In order to help you to reproduce this issue, we require the following information:

  • Bizagi version

We look forward to hearing from you

photo
1

I'm having the same problem, my Bizagi version is 10.7.0.2264

/lBfpAfJEL+f02SCJTjOPRQAAAAAElFTkSuQmCCAA==

any advice ?

photo
1

Dear Victor,

In order to solve it, please use our latest 10.7 version. Please download it from: https://bizagi.sharefile.com/d-s24c7974f48d437e8

Best Regards

photo
1

Could you please share the Bizagi Engine latest 10.7 version ?

Thanks !

photo
2

Dear Victor,

Please download it from your bizagi.com account. We know that you are one of our clients. if you cannot find it, please request it through our Ticket Platform according this article: http://help.bizagi.com/bpm-suite/en/index.html?supportguide.htm

Regards

photo
1

Dear Juan,

Thanks for the information ;)

Regards

photo