In Progress

PM Source: BizAgi.EntityManager.ClassGenerator Message: Could not find the BizAgi.EntityManager.Entities assembly

Hello
What may cause this error?

=====================================================

Error Type: ERRORUNKNOWN

Error

Message:

{"status":"error","code":"UNKNOWN_ERROR","type":"UnknownException","message":"Could

not to process the request.","innerExceptions":"Date Time:

11/28/2013 1:20:59 PM

Source:

BizAgi.BL

Message:

Could not find the BizAgi.EntityManager.Entities assembly

Stack Trace:

at BizAgi.BL.CBLClassGenerator.GetAssembly()

at

BizAgi.Web.Services.AshxRedirection.Render.RenderAshxHandler.ProcessRequest(HttpContext

context)

at

BizAgi.Web.Services.AshxRedirection.Render.RenderRedirection.HandleRequest()

at

Bizagi.Web.RestServices.Framework.AshxRedirection.AshxResources.Implementation.AshxServicesResourcesManager.<>c__DisplayClass2.b__1()

at

Bizagi.Web.RestServices.Framework.GenericRestHandler.Implementation.RestServicesHandler.ProcessRequest(HttpRequestModel

requestModel)

at

Castle.Proxies.Invocations.IRestServicesHandler_ProcessRequest.InvokeMethodOnTarget()

at Castle.DynamicProxy.AbstractInvocation.Proceed()

at

BizAgi.Commons.ServiceLocator.LazyServiceWrapperInterceptor`1.Intercept(IInvocation

invocation)

at Castle.DynamicProxy.AbstractInvocation.Proceed()

at

Castle.Proxies.IRestServicesHandlerProxy.ProcessRequest(HttpRequestModel

requestModel)

at BizAgiBPM.Rest.RestServicesHttpHandler.DoRequest(HttpContext

context)

at BizAgiBPM.Rest.BaseHandlerController.ProcessRequest(HttpContext

context)

-------------------------------------------------------Date Time:

11/28/2013 1:20:59 PM

Source:

BizAgi.EntityManager.ClassGenerator

Message:

Exception in EntityBuilder Could not find the

BizAgi.EntityManager.Entities assembly

Stack Trace:

at BizAgi.EntityManager.ClassGenerator.EntityBuilder.GetAssembly()

at BizAgi.BL.CBLClassGenerator.GetAssembly()

-------------------------------------------------------Date Time:

11/28/2013 1:20:59 PM

Source:

BizAgi.EntityManager.ClassGenerator

Message:

Could not find the BizAgi.EntityManager.Entities assembly

Stack Trace:

at BizAgi.EntityManager.ClassGenerator.EntityBuilder.GetAssembly()

-------------------------------------------------------"}

Comments (13)

photo
0

Hi!!! I'm facing the same issue, but after following the above suggestion still in the same place.Here is the error message I got.

{"status":"error","code":"CASE_CREATION_ERROR","type":"CaseCreationException","message":"Automatic

task failed. ID task=853, ID case=201. Error Evaluating Rule

11057:SetDateAndApplicant - Error Cannot perform setxpath for a

Parameter/Replicated entity, xpath=VacationRequest.Applicant value=3 -Exception

in EntityBuilder Could not find the BizAgi.EntityManager.Entities

assembly."}

I'm trying to run the Vacation Leave request model I downloaded from the xchange page.Thanks in advance for any guidance!

photo
0

Dear Diego,

Please restart your IIS with iisreset in order to take the changes.

Regards

photo
1

Got the same problem and deleting temporaries and restarting IIS did not solve the problem.

However, I looked in log.txt file in C:\Bizagi\Projects\[PROJECTNAME]\Temporary\EntityManager

And found a strange message: "Unrecognized escape sequence".

I went further in the search and discovered a string field to witch a gave a constant value in the format "C:\path\subpath".

It seams Bizagi generate a Entity Class in C# and presents a problem when compiling it. I just altered the default value to empty string and it solved.

Strange as it seams ...