Answered

How do you stop the float attribute rounding to 2DP

Hi,

I have used a float attribute for an exchange rate. This needs to be to 5 decimal places. According to https://help.bizagi.com/bpm-suite/en/index.html?attribute_types.htm "Store floating point numbers in 8 byte binary format with 15 significant digits of precision." so I believe this to be to correct attribute. However, when I enter a new exchange rate to 5 decimal places it automatically coverts it to 2 (see attached)

Thanks

Comments (5)

photo
1

Dear Amber

In Bizagi Studio, you can specify the "Decimal Places" under the Format tab on the Properties of that field.

So, if you need 5 decimal places specify 5.

Hope this helps!

Best Regards

photo
1

Hi,

Thanks for your response, I assume you are referring to the 'format tab' within form design? If so, that would work if the field was being used in a form, but it is a parameter entity and only ever updated in the work portal for the sole purpose of being used in calculations. Is there another format tab elsewhere in Bizagi that you are referring to, if so please advise?

Thanks

photo
1

Dear Amber

In the "Expert View" of Bizagi Studio, you can create your own Add and Edit forms for your Parameter entity.

To create these forms, please follow these steps

- Go To Expert View In Bizagi Studio

- Select Entities on the side bar

- Expand Parameter

- Right click on your Parameter Entity

- Select Advanced Properties

- Here you can create your own Add and Edit forms and specify the formatting for your attributes of type Float.

Hope this helps!

Best Regards

photo
2

Thank you, your second response answered my question - completed and testing ok

photo
1

Thank you, your second response answered my question - completed and testing ok