In Progress

Error Loading Forms Editor: Could not load file or assembly 'CefSharp.Core.dll'

I am using Bizagi 10.7 and some of my machines are presenting an error when trying to edit a form.

The operating systems are Windows 10 and Windows Server R2 2012 Standard.

Tryied all sort of things without success.

The complete error msg is bellow:

Could not load file or assembly 'CefSharp.Core.dll' or one of its dependencies. Não foi possível encontrar o módulo especificado.

System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.IO.FileNotFoundException: Could not load file or assembly 'CefSharp.Core.dll' or one of its dependencies. Não foi possível encontrar o módulo especificado.

at BizAgiStudio.Forms.Modeler.Web.Editor.View.FrmModelerWeb.InitializeBrowser()

at BizAgiStudio.Forms.Modeler.Web.Editor.View.FrmModelerWeb..ctor(Action`1 formclose, IModelerWebPresenterFactory modelerWebPresenterFactory, IWindowsFormsInvoker windowsFormsInvoker)

--- End of inner exception stack trace ---

at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)

at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)

at BizAgi.Commons.DependencyInjection.DependencyInjector.AssistedInjection.ByConstructor.AssistedFactoryProvider.InterfaceMethodInterceptor.Intercept(IInvocation invocation)

at Castle.DynamicProxy.AbstractInvocation.Proceed()

at Castle.Proxies.IModelerWebFactoryProxy.Create(Action`1 formclose)

at BizAgiStudio.Forms.Modeler.Web.FormsModelerProcessArchitectureFacadex86.OpenForm(Guid idForm, Action`1 formClosed, Boolean isShowDialog)

at BizAgiStudio.Forms.Modeler.Web.WebFormsModelerFacade.OpenForm(Guid idForm, Action`1 formClosed)

at BizAgiStudio.Forms.Modeler.Web.WebFormsModelerFacade.OpenForm(Guid idForm)

at Castle.Proxies.Invocations.IWebFormsModelerFacade_OpenForm.InvokeMethodOnTarget()

at Castle.DynamicProxy.AbstractInvocation.Proceed()

at Castle.DynamicProxy.AbstractInvocation.Proceed()

at BizAgiStudio.EntityManagerPlugin.Logic.FormsPlugInLogic.EditForm(Guid formId, Int32 formsVersion)

at BizAgiStudio.EntityManagerPlugin.Logic.FormsPlugInLogic.OpenForm(FormsLogicParam p)

at BizAgiStudio.Carrousel.Controls.CarrouselContainer.HandleShapeClickForDefineForms(ModelerProcessControl processControl, BaseShape shape)

at BizAgiStudio.Carrousel.Controls.CarrouselContainer.OnModelerProcessControlShapeClick(Object sender, CrainiateElementEventArgs`1 e)

at BizAgi.PM.UI.Controls.DiagramFlowChart.OnElementClick(Element element)

at Crainiate.ERM4.Diagram.OnClick(EventArgs e)

at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)

at System.Windows.Forms.Control.WndProc(Message& m)

at Crainiate.ERM4.Diagram.WndProc(Message& m)

at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Comments (7)

photo
1

Got to solve using the following strategy:

1) Uninstalled all Microsoft C++ Redistributable packages that are installed in the machines;

2) Installed new ones (x86 and x64) - 2012 and 2013 (in one machine on ly worked after these two versions were installed. In other, 2013 was suficient).

Don´t know exactly why, but solved the problem for now.

photo
1

Same problem returning in another client.

Windows Server this time. 2 weeks lost in this ...

photo
1

Dear Carlos,

Have you already reinstalled your .NET framework? Please try it and tell us the results.

We look forward to hearing from you

photo
1

I've the same problem.

The host is Windows Server 2012 R2 and after of to search in the folder c:\programs file\bizagi\bizagistudio\studio all ".dll's" are there.

Could you help?

photo
1

Dear Alexandre,

Please reinstall your .NET Framework and try again.

We look forward to hearing from you

photo
1

In fact, we decided to redo all Windows Server 2012 R2 instalation,

but for no avail.

We did not figure

out how to reinstall .net framework. It is not available in Programs &

Features in Control Panel.

If we disable it

in Server Configuration, Windows disables GUI. Got some problem with that

(solved with this article

https://blogs.technet.microsoft.com/askcore/2014/04/24/removing-net-framework-4-54-5-1-removes-windows-20122012r2-ui-and-other-features/).

If we try to

install from an Offline package, it show the message : ".NET Framework

4.6.1 or a later update is already installed on this computer".

Where to go ?

photo
1

Dear Carlos,

Thank you for your feedback. Please send us message from Windows event viewer regarding Bizagi issues. In addition, send us a screenshot of this problem.

We look forward to hearing from you

photo