Solved

Error: 21897 Create site


The application respond correctly. When created on a website stop respond.
When I create a site in iss the application responds with an error below.
Configure the application
131017101945208036
Configure the site.
13101710194654209
BizAgiVersion
10.1.0.2020Operational System Microsoft Windows NT 6.1.7601 Service Pack 1Page Error http://workflow.tostoadv.com/default.aspxError Message

Code error: 21897 Application start failed. You may need to update the project.

Application start failed. You may need to update the project. Application Name was not initializedSource System.Web

BizAgi.UI

BizAgi.Defs

Stack Trace at System.Web.UI.Page.HandleError(Exception e)

at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

at System.Web.UI.Page.ProcessRequest()

at System.Web.UI.Page.ProcessRequest(HttpContext context)

at ASP.default_aspx.ProcessRequest(HttpContext context) in c:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\1b870817\46692253\App_Web_a330r3g2.6.cs:line 0

at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)Inner Exception BizAgi.Defs.UIBaseException: Application start failed. You may need to update the project. ---> System.NullReferenceException: Application Name was not initialized

at BizAgi.Defs.UtilServer.GetApplicationName()

at BizAgi.BL.CBLConfiguration.LoadSettingsForAppWeb(HttpServerUtility oServer)

at BizAgi.UI.WFBiz.CGlobalAsax.Application_Start(Object sender, EventArgs e)

--- End of inner exception stack trace ---

at BizAgi.UI.WFBase.CSite.OnInit(EventArgs e)

at System.Web.UI.Control.InitRecursive(Control namingContainer)

at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

photo
0

Dear Fernando,

Are you working with x32 Bits or x64 Bits technology?

What version of Bizagi do you have?Please, follow this article to set up the IIS: http://wiki.bizagi.com/en/index.php?title=IIS_Installation

photo
0

Y working with x64 bits

Bizagi enterprise 10.1.0.2020

photo
0

Dear Fernando,

It is a site in a new server? I mean, you want to move the application web of Bizagi to another machine?

Sometimes this error occurs when you restore a database in a SQL server and the collation is different.

Can you please post an image of the issue? and also can you add the message you get in event viewer?

Thanks in advance

photo
0

Dear Fernando,

If the site is in the same machine where develop environment is, you do not need to create a site in IIS Server. Bizagi Studio creates it automatically and you just run it from green button.

Runprocess_03

If you need more information, please read this article in order to execute your project: http://wiki.bizagi.com/en/index.php?title=Execute_the_Application_with_Process_Wizard

Regards