Answered

Custom virtualization is only calling the entity's constructor and Init methods

I tried creating a custom virtualization using the BigAgiMySQL sample that is provided in this article: http://help.bizagi.com/bpmsuite/en/index.html?custom_virtualization.htm. I added trace statements that log to the Windows Application event log so I can understand how the methods are being called by the Bizagi engine. I invoked both "Test Provider" and "Test Virtual Entity" in Bizagi Studio. Output from both reports that everything is OK. In my trace output, I see my custom provider methods being called, but I see only my custom entity's constructor and Init methods being called. The engine is not calling my other custom entity methods:AddEntity

UpdateEntity

DeleteEntity

GetEntityInstance

GetAttributeValue

GetEntityInstancesTable

ExistsEntityInstance (both method signatures)I am running version 10.6.1.2184. Is there a known problem with custom virtualization?

Comments (11)

photo
0

I recompiled the BizagiMySQL project as you instructed. I also followed the step-by-step instructions at the posted article. I still get the same error as before:

Class BizagiMySQL.CMySQLProvider in assembly BizagiMySQL does not implement IProviderDA interface.

photo
1

Is it possible that the evaluation edition (10.6.1.2075) does not support data virtualization? As I mentioned earlier, I have a non-public edition (10.6.1.2184) that successfully loads the assembly and calls some of the methods. The evaluation edition fails to even load the assembly, complaining that it does not implement this IProviderDA interface.

photo
1

I do not agree with the status being changed to Answered. I still am unable to get this feature to work, even after carefully following the steps suggested.