In Progress

Could not load file or assembly 'ScintillaNet.dll'

Hi,

I'm currently trying the follow the tutorial 'First Workshop for Product Evaluation'.

After creating an Expression, in Activity Actions chapter), I have the following error message:

System.IO.FileLoadException: Could not load file or assembly 'ScintillaNet.dll' or one of its dependencies. L’application n’a pas pu démarrer car sa configuration côte-à-côte est incorrecte. Pour plus d’informations, consultez le journal d’événements d’applications ou utilisez l’outil de ligne de commande sxstrace.exe. (Exception from HRESULT: 0x800736B1)File name: 'ScintillaNet.dll' at BizAgiStudio.Plugin.CodeEdition.ScintillaBasedEditor..ctor() at BizAgiStudio.BusinessRulesPlugIn.FrmRuleTester.InitializeComponent() at BizAgiStudio.BusinessRulesPlugIn.FrmRuleTester..ctor(Boolean usingLibraryRule) at BizAgiStudio.BusinessRulesPlugIn.FrmRuleProperties.tryCompileRule(DataTable& errorSchema) at BizAgiStudio.BusinessRulesPlugIn.FrmRuleProperties.btnOK_Click(Object sender, EventArgs e) at System.Windows.Forms.Control.OnClick(EventArgs e) at DevComponents.DotNetBar.ButtonX.OnClick(EventArgs e) at DevComponents.DotNetBar.ButtonX.OnMouseUp(MouseEventArgs e) at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks) at System.Windows.Forms.Control.WndProc(Message& m) at DevComponents.DotNetBar.PopupItemControl.WndProc(Message& m) at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m) at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m) at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

I try to copy the file "ScintillaNet.dll" stored in \Bizagi\Bizagi Xpress\Studio into \windows\assembly\ as suggested in a previous post. But I still have the same issue.

Thanks in advance.

photo
0

Update:

After installing MIcrosoft Visual C++ Redistributable x86, it works fine.

It appears that in our installation, we had only the 64bits version of the package.

The problem is now solved.

photo
0

Hello Hubert,

I am currently having the same problem and even if I install Microsoft Visual C++ Redistributable x86 and copy the .dll to the assemblies folder the error continues to appear.

Was it necessary for you to make any additional operation?

Any help would be kindly apprenciated,

Best regards

Edgar

photo
0

Hello Hubbert,

As it turns out I had to install the 2008 Microsoft Visual C++ Redistributable x86 and not the 2010, for some reason only with 2008 the error did not occur.

Thanks for your post,

Best Regards

Edgar