Solved

Could not load file or assembly 'ADOMD' or one of its dependencies. Access denied.

Hi.

I have a standard installation of Bizagi (64 bits, v.10.6) on a Windows Server 2008 R2 DataCenter (64 bits as well). Projects installed on the default path ("c:\Bizagi\Projects") work normally. However, when the project is installed on a different drive and path (i.e. "E:\Bizagi\Projects") do not execute. When trying to run a simple process from Bizagi I get the following error message in the browser:

Could not load file or assembly 'ADOMD' or one of its dependencies. Access denied.

What I have noticed is that temporal files normally created under "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\[ProjectName]" are not created, as if the user running IIS's application pool ("Bizagi 64-Bit ASP.NET v4.0") which is "ApplicationPoolIdentity" has no permissions over that folder. I haven't changed any configuration or permissions in IIS or in the any folder. I'm running with the local Administrator account. The process I'm trying to execute is completely basic (1 single activity, nothing else). Remember that projects created on the default path are executed without any issues which means IIS configuration is fine.

If permissions need to be changed, please indicate exactly which user needs which permissions (Full Control, Modify, Read, etc.) on which folders.

Thanks.

Best Answer
photo

Dear Daniel,

By default Bizagi projects are created in a path located as C:\BizAgi\...\Projects\.In this path, all information regarding the processes, the data model, forms, rules, performers and integration is stored and referenced. If you wish to change the default path of your project in the development environment (while in automation stages of the project), follow the next steps in which files are moved and references are updated to the new paths.

For further information check this article: http://help.bizagi.com/bpmsuite/en/index.html?project_location.htm

Regards

Comments (8)

photo
0

Dear Daniel,

By default Bizagi projects are created in a path located as C:\BizAgi\...\Projects\.In this path, all information regarding the processes, the data model, forms, rules, performers and integration is stored and referenced. If you wish to change the default path of your project in the development environment (while in automation stages of the project), follow the next steps in which files are moved and references are updated to the new paths.

For further information check this article: http://help.bizagi.com/bpmsuite/en/index.html?project_location.htm

Regards

photo
0

Thanks for the answer Juan. However, in this case I'm not changing the path of the project after it was created. All projects failing with that error were in fact created in a different path from the very beginning. Should I follow all the steps described in the article?

Regards.

photo
0

Dear Daniel,

In order to solve this issue, check the Application Pool into your Advance Settings of IIS Manager. Verify that the pool is Bizagi 64-Bit ASP.NET.

In addition, you suggest to verify the steps described in the article.

Regards

photo
0

The application pool has never been changed, as you can see in the attached image. You can also see the path I indicated earlier in the bug.

I should mention that the error appeared after the server was resetted. Before that it was working perfectly.Thanks.

photo
0

For further details here is the list of App pools in IIS.

photo
0

Dear Daniel,

Thank you for your feedback. In order to solve this issue, give rights to NETWORK SERVICE user to WebApplication Folder and subfolders

25k37g4

Regards

photo
0

Thanks Juan for the answer.

The permissions were already set according to your image in the previous post. As you can see in the attached screenshot, the permissions for Network Service ("Servicio de red" in Spanish) are already there, I haven´t changed anything. I'm including the ACL details for that particular folder as it may give you a clue as to what is causing the error.

photo
0

Dear Daniel,

A member of our support team will contact you

Regards