Solved

Connect to Alfresco Community 5.2

Hello, Guys!

I'm new to Bizagi and I'm trying to connect it to Alfresco Community 5.2 version. I have troubles with the url (none of the shown in the tutorials worked). Can anyone tell me what url should I use and if I should make any additional changes to Alfresco?

Thank you in advance!

Best regards,

Albena Mincheva.

Comments (6)

photo
1

Dear Albena,

Have you tried this one? To configure Alfresco as the ECM system for Bizagi, first ensure that your Alfresco version complies with the CMIS 1.0 standard.For instance, the Alfresco 3.4a version (includes community edition) supports CMIS 1.0.

You may confirm there is CMIS 1.0 support and look up the CMIS Web services, by entering the http://localhost:[alfresco_port]/alfresco/cmis URL into a browser:

ecm00_alfresco

For further information: http://help.bizagi.com/bpm-suite/en/index.html?configuring_alfresco.htm

We look forward to hearing from you

photo
1

Dear, Juan

Thank you for your response. I tried to configure Alfresco as in the example, but the url: http://localhost:[alfresco_port]/alfresco/cmis doesn't working for me. I get the following error (see attached images).

In the Alfresco documentation it says that it fully implements both the CMIS 1.0 and 1.1. The options of url that I have for this versions of Alfesco are for CMIS 1.0 AtomPub Service and the url is: http://citstnlab02:9080/alfresco/api/-default-/public/cmis/versions/1.0/atom (see images).

This one doesn't work too. If you have any other suggestions I would greatly appreciate it!

Thanks in advance.

Best regards,

Albena Mincheva.

photo
1

Dear Albena,

Please check the following information:

For Alfresco, the URL corresponds to the below possibilities:

  1. http://[your_server]:[port_number]/alfresco/cmis

In newer versions of Alfresco, those having support for CMIS 1.1, CMIS 1.0 services are published by default at:

  1. http://[your_server]:[port_number]/alfresco/cmisws

If the problem continues, you should check in Alfresco documentation to set up it correctly.

Regards

photo
1

Dear Juan,

I tried:

  1. http://[your_server]:[port_number]/alfresco/cmisws


The response I got is the following xml: 525c2a879e3a200013b96ccebf48f75f


Is that what I'm supposed to get?
I tried it in Bigazi and I get an error again:
386b025b75aea9f55344642d171a15a7
Do you know if this is an issue with Alfresco configuration?
Thank you in advance!


Best regards,
Albena Mincheva

photo
1

Dear Albena,

The idea is to use the URL until cmisws. If the problem continues, we recommend to use Alfresco 5.0 version meanwhile Bizagi supports 5.2 version.

We look forward to hearing from you

photo
1

Hello, Juan!

Thank you very much for your help. I found out that probably Alfresco 5.2 has some bugs and it is not working with the default url (/alfresco/cmisws). I resolved it when I changed the version of Alfresco to 5.0. It is working like charm now!

Best regards,

Albena Mincheva