In Progress

Cannot reassign task, get an "Access Denied" error

Hi,

A user cannot reassign a task using the reassign button (on the left panel) - Bizagi pops up a screen saying "Access Denied. Your account privileges do not permit access to the area you requested" (see attached screenshot).

I have played around with many of the options on the 'Security > Authorization' module and cannot find anything which which allow / prevent users from reassigning a task.

Can you point me to the correct Authorization menu item.

Thanks,

Iain

photo
0

Dear Lain,

Be sure that the reassign option of the task is enabled. Reassign: If enabled, the Task can be reassigned by the user during the process. By default, the property is disabled. For more information about this option, refer to Work Reassignment.

reassignment2_zoom79Regards

photo
0

Hi Zuan,

The reassign option of the task is enabled. If it was not enabled, then the user would not be able to see the reassign button in the Bizagi portal (this is the button with a red square around it in the screenshot I attached).

I have read the entire Work Reassignment section of your user guide and have followed all the steps - still I get the "Access Denied" error when logged in as a user that is not a process administrator.

Thanks,

Iain

photo
0

Hi Juan,

The case security is public and the user who is getting the "Access Denied" error can search for and query any case. Further, I tried granting the user privileges on the case using the CHelper.GrantCaseAccess function but am still getting the error.

I think the problem is with the access rights. As I said in my first post, I have worked through all the access rights menu but cannot find the one that grants access to reassign cases.

If I had many days to try every combination of options I could probably figure it out, but it would be far easier for you to speak to a developer and find out which authorisation options gives access to the reassign feature.

So I ask again, please could you find this out for me. Posting links to your help file does not help me. I have already read all the help file entries about Portal Security and tried all the suggestions. Nothing is working.

Thanks,

Iain

photo
0

Dear Lain,

After we checked this issue with our support team, we found that updating your version to the latest solve it. Please, download and install 10.6.1 version from http://www.bizagi.com/en/bpm-suite/bpm-products/studio.

Best Regards

photo
0

Thanks.