Completed

Error while importing vsd files when Visio is not installed

When first clicking on the Visio import button, BizAgi indicated that at least Visio 2003 had to be installed.

Now clicking on the Visio import button generates the following message, "An error ocurred while trying to import Visio file: Object reference not set to an instance of an object."

I uninstalled and reinstalled BizAgi thinking the problem was related to reinstalling Visio 2003 after BizAgi was installed, but same error message pops up. The computer is running Win XP SP3.

Thanks for any suggestions.

Best Answer
photo

Thank you for the valuable feedback.

Based on the comments in this post and from other members of the community, we understand it would be useful to have more specific and controlled error messages when importing models, for example when Visio or Word are not installed.

This idea is already in progress, and it will be released in the upcoming version.

Comments (13)

photo
0

Daisuke Okuda wrote:

Dear Stephanie,

There is no current option for that.

This is registered as an improvement possibility for a future release.

Best regards,

Thank you! I hope it's released soon!

photo
1

Hi! I am trying to import Visio file (with vsdx ext) but it is not allowing me. However, vsd file is OK. It would be great if you can let me know how to proceed.

Thank you

photo
1

Dear Joy,

Bear in mind the following article: http://help.bizagi.com/process-modeler/en/index.html?import_from_visio.htm

In addition, the 3.1 version supports Microsoft Visio 2010, 2007, 2003.

Regards

photo
photo
1

Hi there,

I still have this problem running version 3.1.0.011 where I get the error "An error occured while trying to import visio file: visio is not installed. You need at least " visio 2003 installed.

Please advise.

photo
1

Dear Neil,

To solve it, please upgrade to 3.1.0.034 version from: https://bizagi.sharefile.com/d-s69f9fc6da5e4e0eb.

The MS Visio needs to have a license in order to be used by the modeler to import/export diagrams correctly.

We look forward to hearing from you

photo