Not a Problem

Unable to create process description after the pool already has diagram elements in it

I'm going through and trying to add in documentation to my diagrams and once I have diagram elements located with a pool I can't add a description to the pool. While I can right click and see where the description should go, the magnifying glass is disabled and I cannot type into the Description area. If there are no items in the pool however, I can add a description and magnifying glass works fine.

Best Answer
photo

Actually, once I right click I can start typing a pool description. There's no need to select Properties or anything else from the context menu at all.

photo
0

Dear Jeff,

Thank you for your feedback.

Could you please post a screenshot of where does this occur and how the problem shows up?

Best regards,

photo
0

Sure.

I open the model, I select a pool, in this case I have the top pool selected. I cannot type into the description field at all.

Sheerly by accident however I have found that if after left clicking on the pool to select it if I right click on the pool title the elements inside the pool are no longer selected and I can enter a pool description. But if I just left-click on the pool once, I cannot.

photo
0

Dear Jeff,

Thank you for the detail provided.

Indeed, left-clicking on the pool will select the pool as well as all its inner elements.

This is why, you will not be able to edit properties such as the name or description for all of these elements at once (similarly to selecting all elements, you may use other options such as changing their color from the ribbon's menu).

To edit a pool's description, it is correct to use the right-click and select the properties so that you ensure you are viewing only the properties for that pool and no additional elements.

Best regards,

photo
0

Actually, once I right click I can start typing a pool description. There's no need to select Properties or anything else from the context menu at all.