Solved

Silent installation of Process Modeler via SCCM

Good afternoon,

I've read the documentation with regards to the silent installation, and recorded the installation on both 32 and 64 bit Windows 7 machines for SCCM deployment. The install package in SCCM calls the correct commands and refers to the relevant .iss silent setup file accordingly.

On 32-bit Windows 7 machines, the install does work via SCCM. However, on 64-bit Windows 7 machines, attempting to perform the silent installation fails with an InstallShield error code 3.

When researching the error code, it turns out that error 3 is related to "Required data not found in Setup.iss". This actually is caused by a dialog mismatch in setup.iss.

Upon further checking of the setup.iss file, it turns out that there's actually information missing for the setup.iss file to be valid according to Installshield's documentation - there's no response file header and no information about the program, which should actually be there.

Is there an easy way that this problem could be fixed so that we can deploy to 64-bit machines without issues? I have tried the latest installer 2.3.0.5 as well as the previous 2.3.0.3 release.

Comments (10)

photo
0

Dear Warren,

Thank you for your interest in Bizagi.

We are reviewing this subject and will keep you posted.

Best regards,

photo
0

Daisuke Okuda wrote:

Dear Warren,

Thank you for your interest in Bizagi.

We are reviewing this subject and will keep you posted.

Best regards,

Daisuke

It's now been 3 months since your response - please can you let us have an update as this is still listed as "new" (which presumably it's not any more). We have about 50 users of BizAgi Process Modeler in our university but staff cannot upgrade it themselves due to the IT Windows 7 policy. And as Warren notes in his initial post, the silent install doesn't work. Our IT department is reluctant to carry out "point upgrades" on a per-user basis as this makes a lot of work for them, so at present we're stuck with not being able to upgrade to newer versions as and when they are released.

Many thanks

Bruce Levitan

photo
0

Hi,

ive got the same problem..

Newest Bizagi Installer 2.4.0.2 andd Win 7 64

It seems that the "User" "System" isnt allowed to run the installer correct.

running the C:\Install\Bizagi\BizAgiPMSetup.exe /S /f1"C:\Install\Bizagi\BizAgiPMSetup.iss" - in the System Context - would write a setup.log, but nothing else happens - no folder, no lnk nothing.

runnning the same line under an Administrative User - but not with elevated rights "run cmd as admin"

the same line works perfect.

How to solve this without killing my shoes?

i solved it with psexec (Version 1.98 or higher)

* copy psexec from sysinternals/Microsoft into %windir%

* be shure its 1.98 or higher

run:

psexec /accepteula \\%computername% -u domain\admin -p password -h C:\Install\Bizagi\BizAgiPMSetup.exe /S /f1"C:\Install\Bizagi\BizAgiPMSetup.iss"

-h is the important parameter!

cheers

photo
0

Unfortunately, version 2.5 (even with its separate 64bit installer) clearly has exactly the same symptoms as the other versions.

We don't want to have to run the psexec command as mentioned above as that in theory is revealing the domain admin username and password to anyone who has rights our SCCM server, and that is a potential security risk which we don't want to take.

We get the same error (-3) every time which clearly shows that the installer does not allow for the SYSTEM user to be a valid installer user, which is quite frankly not good enough.

Can this please be looked into as a matter of urgency?

photo
0

We have hit the exact same problem. We install all software on client machines by using the SYSTEM user.

98% of software has absolutely no issues with it (The only exception so far is MS SQL Server, which we have solved using a scheduled task).

While we cannot deploy the software to any of our users evaluation of the full BPM suite is put on hold.

photo
0

Here is my solution for version 2.5:

First create an administrative Installation.

Example:

BizAgiPMSetup-x64.exe /v"/a for x64

Now run the MSI createt in the administrative installallation path with the parameter ISSETUPDRIVEN=1to avoid the "Run Setup.exe Popup"

Example:

MsiExec.exe /i "Bizagi Process Modeler.msi" ISSETUPDRIVEN=1 /qb
Thats all, it´s working great with SCCM.

photo
0

Thank you Markus, this works very well.

Is there an easy way to prevent the registration page from opening? We would like to register as a company and not have every individual user having to click through that process.

Also, does the software check for available updates? Is it possible to deactivate this?

I have not found any registry settings, only a user specific settings.config which would require extra effort to deploy to every user profile.

photo
0

Benjamin Reiter wrote:

Thank you Markus, this works very well.

Is there an easy way to prevent the registration page from opening? We would like to register as a company and not have every individual user having to click through that process.

Also, does the software check for available updates? Is it possible to deactivate this?

I have not found any registry settings, only a user specific settings.config which would require extra effort to deploy to every user profile.

Benjamin,

If you're in an Active Directory environment, I'd be using Group Policy Preferences to deliver the settings.config file you mentioned. This can be copied from a server down to %APPDATA%\Bizagi Ltd\Bizagi Process Modeler\settings.config in the Files section of your Group Policy, and you'd add some item-level targeting so that the file only copies down if the Bizagi executable is present.

You may already have a Group Policy in place for similar settings like that, so it may be worth amending that if you have one. It's saved me considerable headaches when wanting to bring down either files to the user's profile or registry settings that are program specific.

I did an uninstall, clear off the files in the profile (but backed up settings.config), reinstalled it, copied back settings.config, and voila - no nagging. However, you may need to copy down settings.config to a different machine and try it out first as wlel and I'll try to do that myself too.

Markus,

Very nice find indeed on the installer side of things. I did try the /v /a switch with previous installers (or waited for the MSI to extract out and copied it) - however what used to happen was that it didn't allow you to remove the program in Programs and Features. It seems to be not the case now and so that's a positive step in the right direction.

I would hope though that Bizagi still make their installer properly compliant - after all, as Benjamin rightly says, almost everything else works in a compliant way as the SYSTEM user.

photo
0

Benjamin Reiter wrote:

Thank you Markus, this works very well.

Is there an easy way to prevent the registration page from opening? We would like to register as a company and not have every individual user having to click through that process.

Also, does the software check for available updates? Is it possible to deactivate this?

I have not found any registry settings, only a user specific settings.config which would require extra effort to deploy to every user profile.

Hi Benjamin

Did you find a solution to this? Copying settings.config used to work with version 2.7 but it won't work now with 2.8...

photo
0

Dear IT,

A member of our support team will contact you.

Regards