Answered

Object reference not set to instance of an object

Hello,

I am having trouble saving my process as I keep getting the message in a dialogue box that appears when I try to save that says:

"Object reference not set to instance of an object"

I cannot figure out where the trouble is, and which object it is referring to.

Thank you for your swift response.

Kind regards,

Gao

Best Answer
photo

Dear Gao,In order to solve this issue, please upgrade your current version to 3.0.0.015 version. To do so, please download again the installer from: http://www.bizagi.com/en/bpm-suite/bpm-products/modeler#downloadmodeler.Best Regards

Comments (12)

photo
1

Dear Artur,

We recommend to upgrade your current version to solve your issue. Please download it from: https://bizagi.sharefile.com/d-s0764afbf5ed4815a

Regards

photo
1

Hello,

I have similar problem concerns this message: "Object reference not set to instance of an object".

I have a task to convert/move over 100 diagrams from Visual Paradigm to Bizagi.

There is no direct way to do so.

Bizagi accepts only Visio, XPDL and BPMN files format. So I decided to do this task in 2 steps.

1. First step - move diagrams from Visual Paradigm to Enterprise Architect

2. Second step - move diagrams from EA to Bizagi as XPDL file.

And in the second step I stuck. Bizagi do not read a file.

I have a message: "object reference not set to an instance of an objects". What does it mean in this case?

I have checked that there is the same XPDL 2.2 version (EA vs Bizagi).

I have 3.1.0.011 Bizagi Version and Windows 7 64-bit.

How can I solve this problem? Or is there any other way to convert /move diagrams from Visual Paradigm to Bizagi?

Regards

Pawel

photo
1

Dear Pawel,

There is not a way to move from Visual Paradigm to Bizagi. The way how you are trying is correct, however Visio requires to include special elements to import to Modeler. Please check this article: http://help.bizagi.com/process-modeler/en/index.html?import_from_visio.htm

hmfile_hash_17e7154a

Finally, you can upgrade to our latest 3.1.0.040 in which we have applied some fixes: https://bizagi.sharefile.com/d-sc5fc9787ffc4cf19

Regards

photo
photo
1

In my case, I had created a task representing a reusable sub-process and then I changed the name of that reusable sub-process model. The error occurred when I tried to publish the process models as Web pages.

Aligning the task representing the sub-process and the new sub-process name (i.e. the label in the sub-process' pool) the Web publishing worked fine.