Answered

import XPDL from EA - 'Object reference not set to an instance of an object'

Hello

I have to convert/move over 100 diagrams from Visual Paradigm to Bizagi.

There is no direct way to do so.

Bizagi accepts only Visio, XPDL and BPMN files format, so I decided to do this task in 2 steps.

1. First step - move diagrams from Visual Paradigm to Enterprise Architect

2. Second step - move diagrams from EA to Bizagi via XPDL file.

And in the second step I stuck. Bizagi does not accept a file.

I have a message: "object reference not set to an instance of an objects". What does it mean in this case?

I have checked that there is the same XPDL 2.2 version (EA vs Bizagi).

I have 3.1.0.011 Bizagi Version and Windows 7 64-bit.

How can I solve this problem? Or is there any other way to convert /move diagrams from Visual Paradigm to Bizagi?

Regards

Pawel

Comments (6)

photo
1

Dear Pawel,

We require a copy of any of those diagrams. Can please send us one in XPDL standard in order to analyse and do some tests.

We look forward to hearing from you

photo
1

Hi Juan

Thank you, that you want to help me with this task.

I did not answer to this post ealrier, that I sent an email last Friday to 'modeler@bizagi.com' with such a diagram.

I look forward to hearing from you soon.

Regards

Pawel

photo
1

Dear Pawel,

Our product team has resolved this issue. Please download the installer with the solution at: https://bizagi.sharefile.com/d-sb55d05681a943e68

Best Regards

photo
1

Hi Juan

It works - I can import xpdl file from EA. Thank you very much for your & product team help.

I have one more issue to this - do you know why I have got a message (see below) when I want to save a file:

"Error message were found validating the Model.

Do you want to save anyway?"

After that I can work on that model, and save it again (and there is the same message again).

Is it possible to resolve it? Or is it just not important error and we can work on it without any negative impact.

Regards

Pawel

photo
1

Dear Pawel,

The message that you have is because you have a problem in your diagram. Bizagi Modeler has a feature to resolve it.

Bizagi includes a button that validates the element's location. and connections. On the Home tab, in the Model group, click on Validate to start error checking.

Select the error description in the Diagram Validation add-on window in order to correct it.

faq1

faq2

Bizagi Modeler does not validate the notation and the logic used in your diagram. However we offer several types of support to help you through your process modeling and documentation. For more information please refer to Training and Support.

Regards

photo
1

Hi Juan,

thank you for explanation this issue.

Regards

Pawel