Solved

Image in Word and PDF publishing do not keep their ratio (height vs width), giving a distorsion

Hi,

In version 2.6, when publishing in Word or PDF, all images do not keep their ratio (height and width). The issue is that image are not showing ok, height and width being almost at maximum possible in the page in the space left.

For instance, an image with Height of 770 and Width of 1992 shows itself in Word with a ratio of 100% on Height and 29% on Width, thus a distorsion of the image is coming, the picture getting the full page for itself (after the title). This concerns both Diagrams and additional manual images on the diagram.

It appears both in PDF and Word publishing, whatever the model, both in 32 (Windows XP) and 64 (Windows 7) versions.

Strangely, it doesn not appear on all images, but 70% of them.

In the Web publishing or Wikimedia publishing, the ratio is kept correct.

Any idea ?

Best Answer
photo

Dear Frederic and users,

We have produced a fix for the 2.6 version (October 2013) which solves this problem.To install this fix in your installation, download its .zip file with further instructions as well:

Best regards,

photo
0

After some experiments, I found why some images are ok : all images that are 100% sized on both width and height are ok, all others (images that cannot fit natively in the page, so they need to be resized in a smaller size in the documentation) are badly reshaped with one element still at 100% - or the maximum possible - and the other smaller.

So I think the test made when reshaping the image is badly written...

photo
0

And finally, A4 format (not Letter) is not kept after the table of contents.

I changed the page formats to A4 in a new dot model, by starting to copy ModelerTemplate.dot to a new file, changing all pages to A4 (was Letter), and saved this new dot model. Then I used this model.

From the title page until the table of contents, all pages are in A4. Then starting from chapter 1, the page is Letter sized.

Note that the bad ratio images issue is the same whatever I used the original dot files (BizagiTemplate or ModelerTemplate) or modified ones.

photo
0

Dear Frederic,

Thank you for your detailed feedback and pointers.

We will look into this subject and keep you posted.

Best regards,

photo
0

Dear Frederic and users,

We have produced a fix for the 2.6 version (October 2013) which solves this problem.To install this fix in your installation, download its .zip file with further instructions as well:

Best regards,

photo
0

Just a short comment to say that almost all is corrected!

Image ratios are ok, as well as the A4 page format.

Still one element is not kept correctly: the margin. I setup a small margin in the template, but this margin is only kept in the first pages (until the end of the table of content). Starting from chapter 1, the margin is again the original one (wide one). This is not a big issue, since I can quickly change it after.

If it is fixed later on, that would be great!

Thank you

photo
0

Dear Frederic,

Thank you again for the feedback.

This issue will be adjusted in our next release.

Best regards,