Not a Problem

extended attribute relative path

Hi I am using Modeler version 2.5.1.1 but seem unable to set the path of a linked file to a relative path using extended attributes.I can browse to the file - but when I tick 'Relative' the path name does not change. When I save and reopen the extended attribute the 'Relative' tick box is unticked. I have many files I wish to link which need to be relative so I can deploy the process maps via the web on several locations.Hope you can help

Best Answer
photo

Dear Tracy,

Thank you for your interest in Bizagi.

We have seen the reported issue regarding the relative path checkbox for linked files.We will review this subject and keep you posted.

Best regards,

photo
0

Dear Tracy,

Thank you for your interest in Bizagi.

We have seen the reported issue regarding the relative path checkbox for linked files.We will review this subject and keep you posted.

Best regards,

photo
0

Dear Tracy,

We have analyzed this subject and would like to share the following clarifications:

1. Linked files will allow you to refer to given files by their location (these files will not be embedded into the model).If you wish to embed files (as attachments) in your model, you may use the "Embedded files" extended attributes (http://help.bizagi.com/processmodeler/en/index.html?extended_attributes_type.htm).

2. When using a linked file, it is common that you reference a document or image located at a file server (a shared location).When this is not the case (you want to refer to a local file instead), keep in mind that you may use the relative path property to specify that such file will be looked upon the same directory in which your model is.

This is specially useful if you plan on generating Web documentation and to set it up on a different place other than your machine (or similarly, if you plan on moving the .bpm file to another location or making it "portable").

In this way, either the Web output or the .bpm model (both from the application or the presentation actions) will look for that linked file under its same directory.

Having said that, to use the relative path option for your linked files, you would:

1. Define which file is linked to the property.

2. If and only if this file is located in the same directory of your .bpm model (or at sub-folders), you may tick the relative path checkbox to indicate that this file is not to be referenced by its full path.Bizagi will validate if this file is located in the same directory and un-tick the checkbox in case it is not.

3. When publishing your documentation to Web format, you will need to ensure that the linked file is placed as referred to by the relative path.We will analyze the possibility to include usability improvements for this feature in a future release, so that ticking the checkbox shows additional messages to the user and validations kick right away.

Best regards,