Solved

Error when publishing Bizagi models as Web(html)

The following message pops-up when I'm trying to publish the bizagi diagrams as Web files:

"Index (zero based) must be greather than or equal to zero and less than the size of the argument list".

I've found out that when you have an URL address on an extended attribute that contains the { or } characters, Bizagi can't process. Please check it out on the attached picture.

When I simply remove the characters, Bizagi works fine. But the URL ends up being wrong.

Could you include the fixing of this error on the next release?

Best Answer
photo

Dear Adriel,

Thank you for your interest in Bizagi and feedback.

Can you please specify us which version of Bizagi Process Modeler you are using?

In order to efficiently follow up this issue, can you send us the model showing up this error to modeler@bizagi.com?

Best regards,

photo
0

Dear Adriel,

Thank you for your interest in Bizagi and feedback.

Can you please specify us which version of Bizagi Process Modeler you are using?

In order to efficiently follow up this issue, can you send us the model showing up this error to modeler@bizagi.com?

Best regards,

photo
0

The version is 2.4.0.8 (dec 21, 2012).

I've already sent the email.

photo
0

Dear Adriel,

Thank you for the detail.

We are working on this issue and it will be solved in our next release.

Best regards,

photo
0

Dear Adriel,

We gladly announce this issue has been resolved in our latest 2.5 release (June 2013). Best regards,