Solved

¿Any way to embed a published model on sharepoint?

Hello,

I need to embed a published model on SharePoint so the user doesn't have to clic on the file to use the interactive display of the model. I know I have to use Web Parts (Page Viewer maybe?) but can't actually make it work. The problem is that the model file is uploaded in SharePoint, but I don't know if the link in the Web Part should be for a web page (cause the "Index" file extension is html) or a normal file. Hope you can help me with this.

Best rewards,

Camilo

Comments (4)

photo
1

Dear Camilo,

There is only one way to publish your output to your sharepoint. Please follow this article: http://help.bizagi.com/process-modeler/en/index.html?publish_to_sharepoint.htm

After publishing the web output to SharePoint 2010, the default page will not open. What can I do?

When you publish a web output to SharePoint, sometimes the default file will not open the web browser, but instead it prompts to choose a program.

If this is your case there is a configuration error. We suggest following this guided article for your SharePoint 2010 web application settings:

http://www.myriadtech.com.au/blog/James/Lists/Posts/Post.aspx?ID=49.

For further information on how to configure SharePoint 2010 settings please review Microsoft's articles, such as:

http://technet.microsoft.com/en-us/library/cc262107.aspx

Regards

photo
1

Greeting Juan,

I know how to publish my model as a html file, and it works fine. The problem is that I don't want people to clic on the file to actually open it and navigate through it; as an html file I can embed it in SharePoint so when people get to a specific SharePoint page the html file will appear as an "iframe" Web Part without actually clicking the file. I think I need to use this:

<html>

<body>

<iframe src="index.html"

width="100%" height="100%" scrolling="auto"> </iframe>

</body>

</html>

Thing is that when I change the "index.html" for the actual link where the html file is, the Web Part turns blank, as if the html was empty or couldn't load it properly. Hope you can help me figuring this out.

Best Regards,

Camilo

photo
1

Dear Camilo,

We are going to test it and as soon as possible, we will write back

Regards

photo
1

Dear Camilo,

We were able to use the source code you posted here without problem.

  1. <html>
  2. <body>
  3. <iframe src="http://www.w3schools.com"; width="48%" height="100%" scrolling="auto"> </iframe>
  4. <iframe src="index.html" width="50%" height="100%" scrolling="auto"> </iframe>
  5. </body>
  6. </html>

You need to bear in mind the following point:

After publishing the web output to SharePoint 2010, the default page will not open. What can I do?

When you publish a web output to SharePoint, sometimes the default file will not open the web browser, but instead it prompts to choose a program.

If this is your case there is a configuration error. We suggest following this guided article for your SharePoint 2010 web application settings:

http://www.myriadtech.com.au/blog/James/Lists/Posts/Post.aspx?ID=49.

For further information on how to configure SharePoint 2010 settings please review Microsoft's articles, such as:

http://technet.microsoft.com/en-us/library/cc262107.aspx

Regards